• June 18, 2019, 07:37:45 PM
• Welcome, Guest. Please login or register.

The Future of this Forum:

The Inkscape Project will open its first official forum, on the Inkscape website, this August (2019). (Address/link will be provided at that time.) When that happens, new registrations will no longer be allowed in this forum and Inkscape support will be provided in the new forum. This forum will still be open for a while, so that existing topics can be finished, and existing users can have access to their contents. But all potential new members should register on the Inkscape website, and post their questions in the new forum, starting in August. If you have any questions or comments, you can post them here.

Since there haven't been any new messages for so long, and no one has ever replied to this message of mine I'm considering closing this forum entirely, in approx 6 months. If anyone has any comments about that, please feel free to post them.

-- brynn


Author Topic: Inkscape SVGs not showing up correctly in SCAL1  (Read 3789 times)

0 Members and 1 Guest are viewing this topic.

Offline smrlvn

  • Original Member
  • *****
  • Posts: 5
Inkscape SVGs not showing up correctly in SCAL1
« on: November 20, 2013, 02:30:04 PM »
I am new to creating my own SVGs using Inkscape. I created an svg with a hill that has some houses on it, the lines are all straight except the hill itself, however when I import SVG into SCAL some of the lines appear diagonal or slanted. I was able to remedy some of these problems by adding an extra node, making it a corner node, and then clicking "make selected segments lines". However, I couldn't fix them all, it seems like if I edit one it messes up other things. I took some screen shots to attach so you could see what I mean. Any help would be great! Wanted to use this hill for some Christmas cards for my family.


I also wanted to point out that on the ones I haven't been able to fix, those parts of the drawing were done with the square/rectangle tool, where most of the rest of the image that turned out fine was just me drawing lines and connecting them together. I may try drawing lines to make up my houses, as a temporary work around...I will keep you posted if that works.

Thanks ahead of time!

« Last Edit: August 26, 2015, 02:55:09 AM by brynn »

Offline PapaSue

  • Original Member
  • *****
  • Posts: 571
    • http://creationsbypapasue.blogspot.com
Re: Inkscape SVGs not showing up correctly in SCAL1
« Reply #1 on: November 20, 2013, 03:21:12 PM »
Oh my‚ĶSCAL1.  I no longer have scal1 but if you post your svg file I'll take a look and see if I can figure it out.
« Last Edit: December 31, 1969, 05:00:00 PM by Guest »
Susan
http://creationsbypapasue.blogspot.com/
OLDER:  http://papasuecreative.blogspot.com (blog deleted)
Learn, Grow, Create, Share
Macintosh, Mavericks, Inkscape 0.91, eClips1, eCAL2.013

Offline smrlvn

  • Original Member
  • *****
  • Posts: 5
Re: Inkscape SVGs not showing up correctly in SCAL1
« Reply #2 on: November 20, 2013, 03:26:51 PM »
Thanks so much! Here it is without the extra node, since it retains most of the shape this way :)
« Last Edit: December 31, 1969, 05:00:00 PM by Guest »

Offline smrlvn

  • Original Member
  • *****
  • Posts: 5
Re: Inkscape SVGs not showing up correctly in SCAL1
« Reply #3 on: November 20, 2013, 03:29:29 PM »
Actually, looking at this file again. I added a node to the top hill (the one without the houses) on the far left side because that line was curving also, but viewing it SCAL, it now appears like there is no line there at all. I haven't tried cutting it and since it was a vertical line right at the edge of the image, I missed that it appears to be gone.

***Nevermind, test cut shows that the line on the far left is still there, just displays a little funny***

Also noticed that the tree by the truck doesn't show in SCAL either, easily fixed though on the copy I have now by doing Path>Object to Path.
« Last Edit: November 20, 2013, 04:07:50 PM by smrlvn »

Offline PapaSue

  • Original Member
  • *****
  • Posts: 571
    • http://creationsbypapasue.blogspot.com
Re: Inkscape SVGs not showing up correctly in SCAL1
« Reply #4 on: November 20, 2013, 04:07:41 PM »
Well there is good news and bad news I'm afraid.  I've opened your file in eCAL (scal3) and in SCAL2 and both look perfect.  I do not have scal1 but I cannot see anything in your file that would cause a wonk and this point.  HeatherM who frequents this board has SCAL1 I think and maybe she will come along with a clue.
« Last Edit: August 26, 2015, 02:56:37 AM by brynn »
Susan
http://creationsbypapasue.blogspot.com/
OLDER:  http://papasuecreative.blogspot.com (blog deleted)
Learn, Grow, Create, Share
Macintosh, Mavericks, Inkscape 0.91, eClips1, eCAL2.013

Offline smrlvn

  • Original Member
  • *****
  • Posts: 5
Re: Inkscape SVGs not showing up correctly in SCAL1
« Reply #5 on: November 20, 2013, 04:09:33 PM »
Thanks for checking it out for me. I did a test cut and for the size I am using, the slightly curved lines are barely noticeable (and probably only by me since I know about them lol). Maybe I can get SCAL 2 somewhere...I know SCAL 3 will not work with my cutter, but it appears that SCAL 2 is no longer up for sale.
« Last Edit: December 31, 1969, 05:00:00 PM by Guest »

Offline PapaSue

  • Original Member
  • *****
  • Posts: 571
    • http://creationsbypapasue.blogspot.com
Re: Inkscape SVGs not showing up correctly in SCAL1
« Reply #6 on: November 20, 2013, 05:10:42 PM »
Contact support@craftedge.com and ask if they will let you upgrade to scal2....worth a try.  Do not fall for "used" copy sales..you won't be able to get it authorized.

Glad your file worked out!
« Last Edit: December 31, 1969, 05:00:00 PM by Guest »
Susan
http://creationsbypapasue.blogspot.com/
OLDER:  http://papasuecreative.blogspot.com (blog deleted)
Learn, Grow, Create, Share
Macintosh, Mavericks, Inkscape 0.91, eClips1, eCAL2.013

Offline smrlvn

  • Original Member
  • *****
  • Posts: 5
Re: Inkscape SVGs not showing up correctly in SCAL1
« Reply #7 on: November 20, 2013, 05:14:10 PM »
Thanks for the heads up. I will give it a try.
« Last Edit: December 31, 1969, 05:00:00 PM by Guest »

Offline HeatherM

  • Original Member
  • *****
  • Posts: 207
  • Country: 00
    • http://imagesbyheatherm.wordpress.com/
Re: Inkscape SVGs not showing up correctly in SCAL1
« Reply #8 on: November 20, 2013, 08:33:13 PM »
I don't think Craft Edge can sel SCAL2 since the settlement of the lawsuit.  Don't fall for the SCAL2 that are being sold either, they are hacked versions and don't have valid serial numbers.

What version of Inkscape are you using?  There were some conflicts with later versions of Ink and SCAL1.  If you're using SCAL1 then probably your best option is to use an older version of Inkscape.  I think Inkscape 0.46 was the last version released during SCAL1's selling period.  http://sourceforge.net/projects/inkscap ... cape/0.46/

Another thing to try is to select all of your artwork and use Path/Union or sometimes it helps if you use a combination of Union and copying the artwork into a new file.  SCAL1 definitely didn't like any of the Path effects, so artwork created with that needs the Union and copy/paste into a new file treatment.

Often SVG files created in newer versions of Ink look wrong in SCAL1, but usually if you use the preview they look OK or close to OK.
« Last Edit: December 31, 1969, 05:00:00 PM by Guest »
Heather
http://imagesbyheatherm.wordpress.com/
Mac OSX, Inkscape, eClips, Silhouette Cameo