• December 10, 2018, 04:44:23 AM
• Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Need help to avoid extra nodes/lines when exporting for laser cutting  (Read 3482 times)

0 Members and 1 Guest are viewing this topic.

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Hello. Thanks to all the people that help others in this forum.

I have a problem when exporting from Inkscape to a laser cutting file format (dxf, hpgl and plt).

I often import an image into Inkscape (jpg, png, etc.) and use Trace Bitmap to convert it to paths. Depending on the original image I use Brightness cutoff, Edge Detection or Colors (multiple scans) to trace the bitmap.

The laser cutter is a CamFive, and the software is SmartCarve 4.3. It takes dxf, hpgl or plt files.

I have Inkscape 0.92 on a windows 7 computer, and the Uniconvertor installed (https://sk1project.net/modules.php?name=Products&product=uniconvertor&op=download).

For this post I took an image (http://www.supercoloring.com/coloring-pages/toy-train) and traced the bitmap using Brightness cutoff, Edge Detection and Colors (multiple scans). Then, I exported to the 3 file formats (dxf, hpgl and plt).

When I import each file into SmartCarve I get this:


dxf format is very useful because I can use it with technical drawing software (LibreCAD).
hpgl looks clean but it has many small lines when you zoom in.
plt sometimes works well, but not always (also most of our computers at the school have linux based OS, and plt exporting is not working on those).

I use dxf more often, but then I have to cut lines and erase nodes on SmartCarve to clean the image.

Does anyone have an idea about what causes this problem, or about the solution?

Thank you all.

Here you can see the detail of each format:

DXF:


HPGL:


hpgl zoomed in:


PLT:

Offline HeatherM

  • Original Member
  • *****
  • Posts: 204
  • Country: 00
    • http://imagesbyheatherm.wordpress.com/
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #1 on: February 20, 2018, 06:21:19 PM »
Hello and welcome!  Have you seen this page?  http://wiki.imal.org/howto/inkscape-and-lasercutter  Hopefully there is something there that will help.

Sadly, dxf files are very heavy on nodes for curves and there isn't much that you can do about it in Inkscape.
Heather
http://imagesbyheatherm.wordpress.com/
Mac OSX, Inkscape, eClips, Silhouette Cameo

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #2 on: February 22, 2018, 06:52:44 AM »
Have you seen this page?  http://wiki.imal.org/howto/inkscape-and-lasercutter  Hopefully there is something there that will help.
Thank you HeatherM, I will take a look.

Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #3 on: February 24, 2018, 10:37:32 AM »
Welcome to the forum!

I don't clearly understand your question, relative to your screenshots.  This is the question I heard:

Quote
I use dxf more often, but then I have to cut lines and erase nodes on SmartCarve to clean the image.

Does anyone have an idea about what causes this problem, or about the solution?

Are the lines that you have to remove all those lines which seem to meet at one point?  Do you know where those lines are coming from?  Are they somehow a result of converting to DXF?

I'm not set up to handle DXF, so I can't test for myself.

Oh wait.....that's what you see in the cutter software.  So all those lines that meet at one point -- is that the path which the cutter takes, on it's way to the cutting paths?  Or does it actually want to cut all those radial lines (which meet at one point).

As far as using Trace Bitmap, you have to do some editing before you send it to any cutter.  Have you inspected the paths which are created by Trace Bitmap, I mean with the Node tool? 

If you look closely at the cutter preview, you can see the "double lines".  Or else in Inkscape, try this.  After you trace something, add a stroke and remove the fill.  That will make the paths easily visible, and you can see that instead of one nice cutting path, you have 2.  So for a complex image like the train you used in your example, a good deal of editing will be necessary, to result in the single cutting paths that you need.

In some cases where you want to etch an image into wood or whatever, the paths which Trace Bitmap creates are perfect.  But for cutting a design out of some media, more editing is needed.

Multiple scan options would really only be a good choice if the raster image has colors.  For b/w images, a 2 scan Color trace gives essentially the same result as a single scan option, as far as the cutting path.

If you're planning to cut that train image out of something, because of its complexity and how much node editing will be needed after Trace Bitmap, I would probably trace the image using the Pen/Bezier tool.  That will give you the single path that you need.

If you're planning to etch it into some media, I would ask if all those radial looking lines (meeting at the same point) are the ones that you need to edit?  And if not, what editing is needed, which you want to reduce or eliminate?

  • 0.92.2
  • Windows 7 Pro, 64-bit

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #4 on: February 27, 2018, 06:33:43 AM »
Have you seen this page?  http://wiki.imal.org/howto/inkscape-and-lasercutter  Hopefully there is something there that will help.
I tried this solution but wasn't able to make it work. The program does not work on any of our computers. I'll keep trying though, it seems to be a good solution. Thanks!

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #5 on: February 27, 2018, 06:44:46 AM »
Welcome to the forum!

Are the lines that you have to remove all those lines which seem to meet at one point?  Do you know where those lines are coming from?  Are they somehow a result of converting to DXF?

I'm not set up to handle DXF, so I can't test for myself.

Oh wait.....that's what you see in the cutter software.  So all those lines that meet at one point -- is that the path which the cutter takes, on it's way to the cutting paths?  Or does it actually want to cut all those radial lines (which meet at one point).

In Inkscape those lines do not exist/show, it is the cutter software that puts them there. I can open the dxf file on LibreCAD, and those lines are not there, its only the cutter software. Every line that shows on the cutter software is processed by the machine, whether its cut or engrave, if they show, they are part of the design. So I have to erase all those lines in order to cut/engrave the design.

"is that the path which the cutter takes, on it's way to the cutting paths?" no, they are part of the design at this point
"Or does it actually want to cut all those radial lines (which meet at one point)." they will be cut or engraved if I do not clean the design.

If you look closely at the cutter preview, you can see the "double lines".  Or else in Inkscape, try this.  After you trace something, add a stroke and remove the fill.  That will make the paths easily visible, and you can see that instead of one nice cutting path, you have 2.  So for a complex image like the train you used in your example, a good deal of editing will be necessary, to result in the single cutting paths that you need.

In some cases where you want to etch an image into wood or whatever, the paths which Trace Bitmap creates are perfect.  But for cutting a design out of some media, more editing is needed.

Multiple scan options would really only be a good choice if the raster image has colors.  For b/w images, a 2 scan Color trace gives essentially the same result as a single scan option, as far as the cutting path.

If you're planning to cut that train image out of something, because of its complexity and how much node editing will be needed after Trace Bitmap, I would probably trace the image using the Pen/Bezier tool.  That will give you the single path that you need.

Yes, when I want to cut a shape, I create and outline (single line), and engrave the traced design inside. And generally I leave the design with the double line, because of all the editing that is needed to create a single line.
You are correct about the multiple scans being good for color images, but for this post I used the same image for all the trace bitmap options.

If you're planning to etch it into some media, I would ask if all those radial looking lines (meeting at the same point) are the ones that you need to edit?  And if not, what editing is needed, which you want to reduce or eliminate?

Yes, all those radial looking lines are the ones that I erase in the cutter software before etching it. After a while, you get used to it, but we have students designing and using the cutter, so, for them it is a little harder to erase all those extra lines/nodes.

Thanks for your help.

Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #6 on: February 27, 2018, 09:56:26 AM »
I wonder if those lines are created because there are open paths in the Inkscape files?  I mean, so that the cutter software does it's best to close them.  Why it would close them using a point so far away, I have no idea. 

Could you provide an SVG file that I could look at?  I need the SVG file, because for some reason which I have yet to discover, I can't open DXF files.

If the paths are closed in the SVG file, then likely they are closed in the DXF file.  And that would mean my idea is not the problem.  But let's check that off before we move on.

If you saved an SVG from the train image, please attach that.  But if not, then import a raster image into Inkscape, and run Trace Bitmap -- use Brightness Cutoff, please.  Then save as InkscapeSVG.  Then save as DXF.

Please attach the SVG file to your next reply.  And then if you would please make a screenshot of what this new file produces in the cutter software preview, and attach that screenshot.  Thanks :)
  • 0.92.2
  • Windows 7 Pro, 64-bit

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #7 on: February 28, 2018, 09:44:23 AM »
I wonder if those lines are created because there are open paths in the Inkscape files?  I mean, so that the cutter software does it's best to close them.  Why it would close them using a point so far away, I have no idea.

Hello Brynn. That's a good idea, it might be that.

If you saved an SVG from the train image, please attach that.
Yes, I saved the train svg file. Thanks.

*svg train.svg
(277.87 kB - downloaded 92 times)

Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #8 on: March 01, 2018, 11:27:10 AM »
The paths look closed in the SVG file.  I don't know if saving as DXF might have changed something.  Do you know how to look for open paths?  So if you open your DXF file, can you check for that?  But I think I might be on to something more promising.

When I zoom in on your screenshot of the DXF in the cutter software, it looks like the lines originate right between the inner and outer paths, which Trace Bitmap generates.  Look at the screenshot I attached, where I compared your screenshots with the SVG file.

Are all these extra lines connected to areas where there are tiny circular or elliptical sub-paths, which are squeezed in between the inner and outer paths?  I think they are....  And in the area of the wheels, I think Trace Bitmap is not even picking up whole circles, for some of this thinner lines.  So it's not even a solid line there, and instead, is made of part lines, part dots.

A lot of those can probably be eliminated by adjusting the Threshold for the single scan options.  And as we mentioned before, multiple scan option would not be needed for this particular drawing. I think the Threshold number will need to be larger, but I can't remember for sure.

You can also use the Speckle and Optimize Paths on the Options tab, to help eliminate those.  Until developers can make that silly tiny preview larger, unfortunately it will just be trial and error to find the right combination.  Try adjusting the Threshold first, and then the Options tab.

(And if we can't get rid of these tiny sub-paths in any other way, then by all means, try the Color scan, because it doesn't look like that is creating these tiny sub-paths -- at least not as much.)

You can always remove these tiny sub-paths via node editing, I mean while still in Inkscape, but it makes sense to try to avoid creating them in the first place, first.  Plus, down around the wheels ares, this would really be a lot of work, because a lot of those circles aren't even closed circles.

Yeah, the more I look, the more I think these extra lines are connected with those very tiny sub-paths.  I can't say why....  Maybe there's some setting or configuration of the cutter or cutter software....maybe some minimum size that it accepts.  ORrrrr. maybe it sees those tiny paths as being open for some reason?  Or maybe the conversion to DXF makes them into open paths?  I'm not sure how or why it's happening, but it looks like they are all connected to those tiny sub-paths.
  • 0.92.2
  • Windows 7 Pro, 64-bit

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #9 on: March 05, 2018, 08:08:39 AM »
Hello Brynn. Thank you for your new reply. Excuse me for not answering last week.

First, this is how the dxf file looks on another software (LibreCAD):



The paths look closed in the SVG file.  I don't know if saving as DXF might have changed something.  Do you know how to look for open paths?  So if you open your DXF file, can you check for that?  But I think I might be on to something more promising.

I'm not sure I know how to look for open paths... I opened the dxf file and I can see that each shape is made of smaller paths (I suppose they are open). But only the small ones create the undesired lines. I tried and selected one small ellipse and performed path - union, and then it does not create the lines anymore:



When I zoom in on your screenshot of the DXF in the cutter software, it looks like the lines originate right between the inner and outer paths, which Trace Bitmap generates.  Look at the screenshot I attached, where I compared your screenshots with the SVG file.

Are all these extra lines connected to areas where there are tiny circular or elliptical sub-paths, which are squeezed in between the inner and outer paths?  I think they are....  And in the area of the wheels, I think Trace Bitmap is not even picking up whole circles, for some of this thinner lines.  So it's not even a solid line there, and instead, is made of part lines, part dots.

I think you are right about the small sub-paths creating the extra lines. I will try adjusting the threshold/speckle/optimize paths to avoid small unnecessary sub-paths.


Yeah, the more I look, the more I think these extra lines are connected with those very tiny sub-paths.  I can't say why....  Maybe there's some setting or configuration of the cutter or cutter software....maybe some minimum size that it accepts.  ORrrrr. maybe it sees those tiny paths as being open for some reason?  Or maybe the conversion to DXF makes them into open paths?  I'm not sure how or why it's happening, but it looks like they are all connected to those tiny sub-paths.

I went and played with some cutter software settings:



The "combine lines while import the files" seems to be the one creating the extra lines. So, if anyone else is having this problem, you can try that. The problem is if you need to make filled regions with the cutter,
 because the segmented paths do not allow to make filled regions, or if you need to apply different options to any path, you'll have to manually select each segment of that path to work with it, but for engraving, it works well.



Offline HeatherM

  • Original Member
  • *****
  • Posts: 204
  • Country: 00
    • http://imagesbyheatherm.wordpress.com/
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #10 on: March 05, 2018, 11:04:35 AM »
Are all these extra lines connected to areas where there are tiny circular or elliptical sub-paths, which are squeezed in between the inner and outer paths?  I think they are....  And in the area of the wheels, I think Trace Bitmap is not even picking up whole circles, for some of this thinner lines.  So it's not even a solid line there, and instead, is made of part lines, part dots.

A lot of those can probably be eliminated by adjusting the Threshold for the single scan options.  And as we mentioned before, multiple scan option would not be needed for this particular drawing. I think the Threshold number will need to be larger, but I can't remember for sure.

Yes, adjust the threshold higher to prevent all of those little stray bits.  I only use the Brightness cutoff to trace and I think I usually set the threshold around 0.8.  It depends to some extent on the image (color and noise).
Heather
http://imagesbyheatherm.wordpress.com/
Mac OSX, Inkscape, eClips, Silhouette Cameo

Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #11 on: March 05, 2018, 02:54:47 PM »
No worries about delays.  This bulletin board style format is made to accomodate real life distractions!  We'll still be here, whenever you get here :)

Anyway, regarding those very small paths -- you don't really want to etch those do you?  ....Or else wouldn't they end up being sort of islands in the etching?

So even if you can change some settings in the cutter software, so that the radial type paths are not created....I still wonder if you really want those tiny paths to be in the drawing.

I think the tiny paths are a result of the quality of the raster image, combined with the Threshold level you used (I'm guessing probably you used the default level).  Maybe it's been photocopied once too often, or maybe it's just not a clean copy?  But at the Threshold level you used, Inkscape "saw" something which caused it to think there is some kind of tiny shapes there.  (And then the cutter software misinterpretted them.)  But I'm thinking you probably don't want them.

Although of course, you have the final decisions!
  • 0.92.2
  • Windows 7 Pro, 64-bit

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #12 on: March 12, 2018, 07:45:31 AM »
Thank you all.

I was able to produce less tiny paths, that helps a lot.

But there are designs that have small details, so they are unavoidable. Also, when text is converted to paths, I get many lines from it.

I will keep looking for a solution and update this post.

thanks again...

Offline HeatherM

  • Original Member
  • *****
  • Posts: 204
  • Country: 00
    • http://imagesbyheatherm.wordpress.com/
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #13 on: March 12, 2018, 08:16:12 AM »
When you convert text are you using Object to path or Union?  At least on older versions of Inkscape if you used Object to path on text it would have each letter as a separate Path and then Group it together.  I think I read that Smartcarve doesn't like Groups, so check for Groups in your svg.  If you use Union instead it will convert the text into one Path with no Group. 
Heather
http://imagesbyheatherm.wordpress.com/
Mac OSX, Inkscape, eClips, Silhouette Cameo

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #14 on: March 16, 2018, 02:10:18 PM »
When you convert text are you using Object to path or Union?

Hello HeatherM. I tried both, but the lines still appeared. Thank you for the suggestion.

I was trying other options to solve the problem and I found Cenon (http://www.cenon.info/), and with this software I was able to generate a dxf file that does not create lines when imported to SmartCarve. Maybe someone with enough knowledge can compare the code of the files created in Inkscape with the code from Cenon and find an explanation to the issue:


Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #15 on: March 17, 2018, 10:42:49 PM »
Hhmm, based on that info, I'm going to create a bug report.  That will put the situation in front of developers, and they can investigate.

Edit
Actually, before I make the bug report, could you show us the results of Cenon's auto trace?  Does it produce the tiny paths?  Or does it do a better trace than Inkscape?

If it works in SmartCarve because the Cenon autotrace does not create the tiny paths, then that would point to the problem being in SmartCarve.  But if Cenon's autotrace is similar to Inkscape's, that would point to Inkscape's DXF export as the problem.
  • 0.92.2
  • Windows 7 Pro, 64-bit

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #16 on: March 19, 2018, 09:42:00 AM »
Hello Brynn.

I did not process the image with Cenon, I only opened the svg file previously created with Inkscape and saved it as dxf, so it still has the tiny paths created by the Trace Bitmap tool from Inkscape. I'm attaching the svg file (created with Inkscape), the dxf produced by Inkscape and the dxf produced by Cenon.

*inkscape svg train.svg
(277.87 kB - downloaded 78 times)

*inkscape dxf train.dxf
(1581.03 kB - downloaded 83 times)

*cenon dxf train.dxf
(5475.93 kB - downloaded 80 times)


you can see the tiny paths are still on the dxf file created with Cenon:



Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #17 on: March 20, 2018, 10:09:54 AM »
Ok, thanks for that info.  Indeed, I think developers need to know about this (if they don't already).

Thanks again  :)

Edit

https://bugs.launchpad.net/inkscape/+bug/1757212
« Last Edit: March 20, 2018, 03:02:28 PM by brynn »
  • 0.92.2
  • Windows 7 Pro, 64-bit

Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #18 on: March 21, 2018, 03:55:35 AM »
There was a response to my bug report from someone who is not a developer.  But he tried the DXF file which you provided, which Inkscape produced, in 6 other CAD/CAM programs, and it performed flawlessly.  So perhaps rather than use Cenon to export the DXF, using a better cutting software would be more appopriate?

I don't really know the right answer.  Just sharing the info with you.
  • 0.92.2
  • Windows 7 Pro, 64-bit

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #19 on: March 21, 2018, 11:28:10 AM »
Thank you Brynn.

Can you recommend a cutting software? Are there open source options?

thanks again

Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #20 on: March 21, 2018, 01:30:21 PM »
Here's the list he gave.  Personally, I don't know anything about them, whether they are free or whatever.

Fusion 360
SheetCamTNG
Alibre Design
LibreCad
MOI3D
V-Carve Pro

Oh, I think LibreCad is probably free.  But I don't know if it will interface with your hardware.  You'll probably have to do a little research for that - owner's manual or something.
  • 0.92.2
  • Windows 7 Pro, 64-bit

Offline cleversomeday

  • Original Member
  • *****
  • Posts: 76
  • Country: 00
    • Clever Someday
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #21 on: April 01, 2018, 12:33:24 PM »
Based on the fact that the DXF looks good in LibreCAD this does seem to be a problem with your cutter software's import, but I do want to mention that there are several DXF output extensions besides the one that ships with Inkscape. There's a chance one of those would work better for you. As I recall, some of the names are "Better Better DXF" and "Big Saw" or something like that.
-Kay
visit my blog http://cleversomeday.com

Offline jmiranda

  • Jr. Member
  • ***
  • Posts: 11
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #22 on: April 02, 2018, 09:42:01 AM »
--EDIT--
I just tried an option (I read it somewhere but, sorry, I can't find the site again). So, I unchecked the "combine lines while import..."  option on the SmartCarve settings,

then, imported the file (the lines of the file are chopped and you get a lot of small paths), right click on the work area and choose "link line", and all the lines are joined to the original paths!!!!

So, this is not the answer to the problem, but still it might help others who have this problem.
--EDIT--

Hello. I looked at the software list, but buying another software for the laser cutter is not an option right now (and I'm not sure the machine is compatible), thanks for the information anyway. LibreCAD is free and I use it, but it does not drive the laser cutter.

there are several DXF output extensions besides the one that ships with Inkscape. There's a chance one of those would work better for you. As I recall, some of the names are "Better Better DXF" and "Big Saw" or something like that.

Thank you cleversomeday, I tried to install the extensions for Better DXF but it did nor work on Ubuntu or Windows, I also tried older versions of Inkscape, but my guess is that these extensions don't work because of new python libraries.

Thanks anyway, I'll keep trying,
« Last Edit: April 02, 2018, 11:43:58 AM by jmiranda, Reason: found a possible solution »

Offline brynn

  • Administrator
  • *****
  • Posts: 302
  • Country: us
  • Gender: Female
    • Inkscape Community
Re: Need help to avoid extra nodes/lines when exporting for laser cutting
« Reply #23 on: April 02, 2018, 02:23:21 PM »
Oh, I didn't realize Inkscape had other DXF export extensions.  So I've searched through extensions, and here's nice list you can look at!

I don't know which ones work, or work with which operating system, or which cutter hard or software, or which ones might be broken.  This is just a raw list which you can research.

https://inkscape.org/en/~doctormo/%E2%98%85older-dxf-r12-extension-for-plotters-pure-python-version
http://kabeja.sourceforge.net/docs/projects/inkscape.html
http://www.bigbluesaw.com/saw/big-blue-saw-blog/general-updates/big-blue-saws-dxf-export-for-inkscape.html
http://www.bobcookdev.com/inkscape/inkscape-dxf.html
http://tim.cexx.org/?p=590
https://github.com/brad/Inkscape-OpenSCAD-DXF-Export
https://github.com/MakeICT/inkscape-lasercut-dxf
https://github.com/duckinator/dxf2svg
https://github.com/mduggan/dxf2svg

The last 2 might be different versions of the same thing - I'm not sure.
  • 0.92.2
  • Windows 7 Pro, 64-bit